如何把涨跌家数指标放在K线副图上?通达信涨停加亮(含科创板)显示源码指标公式

释放双眼,带上耳机,听听看~!

能不能把涨跌家数指标放在K线副图上?有!

添加之后可以如下图:

如何把涨跌家数指标放在K线副图上?

添加办法之前讲K线加量时提过,以通达信为准。

通达信,CTRL+F进入公式设置,然后如下:

如何把涨跌家数指标放在K线副图上?

重点贴下代码:(注意,复制时可能存在符号变更现象,到时候注意和图片对比)

DRAWKLINE(“880005$C”,”880005$C”,”880005$C”,”880005$C”);

涨跌家数:”880005$C”,COLORWHITE,NODRAW; DD:”880005$C”-REF(“880005$C”,1),COLORLIGRAY,NODRAW;

DRAWLINE(1,REF(“880005$C”,0),1,”880005$C”,0),COLOR999999,LINETHICK2;

冰:600 COLORGREEN;

下:1300 COLORWHITE;

中:2000 COLORLIGRAY;

热:3500 COLORYELLOW;

注意,最后的蓝色代码是对应途中的横线的,区分600家,3500家几个区间值,如果想更改甚至去掉,直接删掉相关代码即可。

删完后如下图:

如何把涨跌家数指标放在K线副图上?

通达信涨停板加亮显示指标:

CS1:=IF(CODELIKE(‘688’),0.2,0.1);

MA1:MA(CLOSE,M1);

MA2:MA(CLOSE,M2);

MA3:MA(CLOSE,M3);

MA4:MA(CLOSE,M4);

MA5:MA(CLOSE,M5);

MA6:MA(CLOSE,M6);

MA7:MA(CLOSE,M7);

STICKLINE(C>=ZTPRICE(REF(C,1),CS1),C,O,2.7,0),COLOR00FFFF;

STICKLINE(C>=ZTPRICE(REF(C,1),CS1),L,H,0,0),COLOR00FFFF;

这个指标非常精准,覆盖的都是涨停板,而且还包括科创板。

位置1,公式名称。用来调出这个公式用的,设置成快捷键即可。

位置2,记得还有参数5-8,对应均线MA5/MA6/MA7。

位置3,注意,是主图叠加,不是附图显示,副图是MACD那些。

位置4,把上面灰色字体的代码粘贴到这里。

创业板股票将以8月24日作为分界线,在这之前的10%加亮,在这之后的20%加亮(单此一条已经足够牛掰了),其他主板和中小板,还是正常10%加亮显示。

软件是通达信,代码如下:

总结下。

第一套代码优势是涨停的、以及涨10%以上全都加亮,劣势是不能区分涨超10%非涨停。第二套代码是只有涨停才会加亮,但偶尔有些没涨停的也会亮。

喜欢第二个的,以后看历史时某天涨幅看着很小却加亮了,可以再打开确认一眼。喜欢第一个的,这几天创业板热,尤其前几天,所以涨幅超10%很多,但现在降温后再看一眼,只有零零星星涨超10%,也并不碍事。

艰难的取舍,看你们需要哪个,或者把两套代码都存在软件,想用哪个用哪个。(只限于通达信)

炒股秘笈

《趋势定位:缠中说禅理论精解》高清PDF文档+缠精准笔源码完整版下载

2021-3-19 21:45:10

炒股秘笈

三种方法判断大势的底部,利用股票黄金分割线套利,跌到这里就会反弹(附:指标源码公式)

2021-3-24 20:42:45