突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

释放双眼,带上耳机,听听看~!

突破上升三角形和突破矩形。

突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

突破上升三角形,一般是发生在股价上升途中的图形,成功率较高,平时应用的也比较广泛。

上升三角形有这么几个特征要注意:向上突破必须要有大的成交量;上升三角形的突破位置一般应在三角形横盘宽度的二分之一到四分之三处,一旦超过横盘宽度的四分之三处才突破的,成功概率会有所降低。

突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

上图是2019年9月份酒鬼酒走势,在周线上走出了三角形突破形态,他的突破时机超过了宽度的4分之三,结果突破后,横盘好久,才再次向上上涨。如下图:

突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

突破矩形:

突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

这个其实就是我们常说的箱体突破,他的特征是:一般盘整的时间较长;突破阻力必须伴随着放量;盘整的时间越长,未来突破之后的行情,就会越大。

突破上升三角形和箱体突破矩形形态买点详解(附:指标公式源码)

上图是宋城演艺周线图,在2018年大盘暴跌的行情中,逆市走出了箱体突破的行情,箱体突破后,精准回踩上轨,然后拉出长阳,短短2周收益超过20%。

最后和大家分一个箱体突破的指标供大家参考:

箱顶:=PEAK(CLOSE,13,1)*0.98 ;

箱底:=TROUGH(CLOSE,8,1)*1.02;

AA:=CROSS(REF(C,1),箱顶);

BB:=CROSS(OPEN,箱顶);

DD:=C>O;

突破:=AA AND BB AND DD;

DRAWTEXT(突破,LOW,’天云复盘矩形突破’);

{1、波浪高低点} TY:=H; HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10); LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10); A:=REF(H,BARSLAST(HD)); B:=REF(H,BARSLAST(LD)); T1:=BARSLAST(HD); T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD); 波浪顶:IF(T1,A,A),COLORGREEN,POINTDOT,LINETHICK1; DRAWNUMBER(波浪顶!=REF(波浪顶,1),H,波浪顶),COLORF00FF0; STICKLINE(T1,A,A,9,0){,POINTDOT},COLORF00FF0,LINETHICK1; 波浪底:=IF(T2,B,B),COLORGREEN{,POINTDOT},LINETHICK1; STICKLINE(T2,B,B,9,0){,POINTDOT},COLORCYAN,LINETHICK1; {2、支撑部分1} QA12:=REF(CLOSE,6)=LLV(CLOSE,2*6+1); QB12:=BACKSET(QA12,6+1); QC12:=FILTER(QB12,6) AND CLOSE=LLV(CLOSE,6+1); QD12:=BARSLAST(QC12); QE12:=IF(QC12,CURRBARSCOUNT,0); QF12:=IF(QD12,REF(QE12,QD12),QE12); QG12:=CONST(QF12); 支撑1:=DRAWLINE(CURRBARSCOUNT=QG12,CLOSE,ISLASTBAR,REF(CLOSE,QG12-1),1),COLOR00FF00,LINETHICK1; DRAWNUMBER(支撑1!=REF(支撑1,1),C,支撑1),COLOR00FF00; DRAWNUMBER(ISLASTBAR,支撑1,支撑1),COLOR00FF00; {3、支撑部分2} QA14:=REF(CLOSE,3)=LLV(CLOSE,2*3+1); QB14:=BACKSET(QA14,3+1); QC14:=FILTER(QB14,3) AND CLOSE=LLV(CLOSE,3+1); QD14:=BARSLAST(QC14); QE14:=IF(QC14,CURRBARSCOUNT,0); QF14:=IF(QD14,REF(QE14,QD14),QE14); QG14:=CONST(QF14); 支撑2:=DRAWLINE(CURRBARSCOUNT=QG14,CLOSE,ISLASTBAR,REF(CLOSE,QG14-1),1),COLOR00FF00,LINETHICK1; {DRAWNUMBER(支撑2!=REF(支撑2,1),L,支撑2),COLOR00FF00;}; STICKLINE(C>支撑1,支撑1,波浪顶,15,1),COLOR005599,LINETHICK2;{箱体画框} STICKLINE(C>支撑2,支撑2,波浪顶,5,1),COLOR005599,LINETHICK2;{箱体画框} STICKLINE(C>支撑1,支撑1,(波浪顶+支撑1)/2,15,1),COLOR005599,LINETHICK2;{箱体画框} {二、箱体部分–支撑到颈线画箱体} QA11:=REF(CLOSE,6)=HHV(CLOSE,2*6+1); QB11:=BACKSET(QA11,6+1); QC11:=FILTER(QB11,6) AND CLOSE=HHV(CLOSE,6+1); QD11:=BARSLAST(QC11); QE11:=IF(QC11,CURRBARSCOUNT,0); QF11:=IF(QD11,REF(QE11,QD11),QE11); QG11:=CONST(QF11); 颈线2:DRAWLINE(CURRBARSCOUNT=QG11,CLOSE,ISLASTBAR,REF(C,QG11-1),1),COLORFFDD00,LINETHICK1; STICKLINE(C>支撑1,支撑1,颈线2,5,1),COLORFFAA33;{箱体画框} STICKLINE(C>支撑1,支撑1,(颈线2+支撑1)/2,5,1),COLORFFAA33;{箱体画框} DRAWKLINE(H,O,L,C); DRAWNUMBER(颈线2!=REF(颈线2,1),C,颈线2),COLOR00FF00; DRAWNUMBER(ISLASTBAR,波浪顶,波浪顶),COLOR005599; DRAWNUMBER(ISLASTBAR,(波浪顶+支撑1)/2,(波浪顶+支撑1)/2),COLOR005599; DRAWNUMBER(ISLASTBAR,颈线2,颈线2),COLORFFAA33; DRAWNUMBER(ISLASTBAR,(颈线2+支撑1)/2,(颈线2+支撑1)/2),COLORFFAA33; {三、箱体部分–过线放量买到支撑1画箱体} T1B:=CONST(LLVBARS(LOW,10)); T1HIGH:=CONST(REF(HIGH,T1B)); CCC:=CONST(CURRBARSCOUNT); T2B:=CONST(BARSLAST(CURRBARSCOUNT>CCC+T1B AND H>T1HIGH)); T2HIGH:=CONST(REF(HIGH,T2B)); T3B:=CONST(BARSLAST(CURRBARSCOUNT>CCC+T2B AND HIGH>T2HIGH)); T3HIGH:=CONST(REF(HIGH,T3B)); 抢钱10:DRAWLINE(CURRBARSCOUNT=T3B+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORYELLOW,LINETHICK1;{,LINETHICK2,COLOR0000FF;} DRAWTEXT(ISLASTBAR, T3HIGH, ‘过线’)LINETHICK1,COLORYELLOW; DRAWNUMBER(抢钱10!=REF(抢钱10,1),H,抢钱10),COLORYELLOW; STICKLINE(C>支撑1,(抢钱10+支撑1)/2,(抢钱10+支撑1)/2,5,1),COLORYELLOW;{箱体画框};

炒股秘笈

根据稳赚工具图套利,每轮牛市都要经历的双底形态源码指标

2020-11-22 13:29:36

炒股秘笈

KDJ选股指标公式:金叉买入,死叉卖出就可以了

2020-11-29 14:20:46